GitHub Advisoryadvisory · PyPI

GHSA-9crx-p357-5vw8 Ajenti Cross-site scripting (XSS) vulnerability

MEDIUM Published 2022-05-17 Modified 2024-09-03 Official page ↗
Aliases
CVE-2014-2260
Ecosystem
PyPI
Packages
ajenti
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-05-01

Affected packages

• PyPI ajenti: < 1.2.15 → fixed in 1.2.15

Description

Cross-site scripting (XSS) vulnerability in `plugins/main/content/js/ajenti.coffee` in Ajenti before 1.2.15 allows remote authenticated users to inject arbitrary web script or HTML via the command field in the Cron functionality.

Related

Alias · CVE (1)

  • CVE-2014-2260 Cross-site scripting (XSS) vulnerability in plugins/main/content/js/ajenti.coffee in Eugene Pankov Ajenti 1.2.13 allows remote… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References