GitHub Advisoryadvisory · npm

GHSA-9cv5-4wqv-9w94 muhammara and hummus vulnerable to denial of service by NULL pointer dereference

HIGH Published 2022-11-01 Modified 2022-11-02 Official page ↗
Aliases
CVE-2022-25892
Ecosystem
npm
Packages
muhammara, hummus
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-690
Reviewed
2022-11-01

Affected packages

• npm muhammara: < 2.6.1 → fixed in 2.6.1 • npm muhammara: >= 3.0.0, < 3.1.1 → fixed in 3.1.1 • npm hummus: < 1.0.111 → fixed in 1.0.111

Description

Impact The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. Patches It has been patched in 3.1.1 and has been backported to 2.6.1 Hummus has a patch in 1.0.111. Workarounds Do not process files from untrusted sources or update. References https://nvd.nist.gov/vuln/detail/CVE-2022-25892 https://github.com/galkahana/HummusJS/issues/463 https://github.com/julianhille/MuhammaraJS/issues/214 https://github.com/julianhille/MuhammaraJS/commit/1890fb555eaf171db79b73fdc3ea543bbd63c002 https://github.com/julianhille/MuhammaraJS/commit/90b278d09f16062d93a4160ef0a54d449d739c51 https://security.snyk.io/vuln/SNYK-JS-HUMMUS-3091138 https://security.snyk.io/vuln/SNYK-JS-MUHAMMARA-3060320

Related

Alias · CVE (1)

  • CVE-2022-25892 The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS)… vulnerability

Weakness · CWE (1)

  • CWE-690 Unchecked Return Value to NULL Pointer Dereference weakness

References