GitHub Advisoryadvisory · npm
GHSA-9cw2-jqp5-7x39 Multiple Content Injection Vulnerabilities in marked
MEDIUM
Official page ↗
- Aliases
- CVE-2014-3743
- Ecosystem
- npm
- Packages
- marked
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-08-31
Affected packages
• npm marked: < 0.3.1 → fixed in 0.3.1
Description
Versions 0.3.0 and earlier of `marked` are affected by two cross-site scripting vulnerabilities, even when `sanitize: true` is set.
The attack vectors for this vulnerability are GFM Codeblocks and JavaScript URLs.
Recommendation
Upgrade to version 0.3.1 or later.
Related
Alias · CVE (1)
- CVE-2014-3743 Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness