GitHub Advisoryadvisory · Packagist

GHSA-9f45-9qrw-pp4v Moodle vulnerable to Cross-site Scripting when algebra filter enabled but not functional

MEDIUM Published 2023-03-23 Modified 2024-04-19 Official page ↗
Aliases
CVE-2023-28332
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-03-23

Affected packages

• Packagist moodle/moodle: >= 4.1.0, < 4.1.2 → fixed in 4.1.2 • Packagist moodle/moodle: >= 4.0.0, < 4.0.7 → fixed in 4.0.7 • Packagist moodle/moodle: >= 3.11.0, < 3.11.13 → fixed in 3.11.13 • Packagist moodle/moodle: < 3.9.20 → fixed in 3.9.20

Description

If the algebra filter was enabled but not functional (eg the necessary binaries were missing from the server), it presented an XSS risk.

Related

Alias · CVE (1)

  • CVE-2023-28332 If the algebra filter was enabled but not functional (eg the necessary binaries were missing from the server), it presented an XSS risk. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References