GitHub Advisoryadvisory · npm

GHSA-9f65-56v6-gxw7 Claude Code Improper Authorization via websocket connections from arbitrary origins

HIGH Published 2025-06-23 Modified 2025-06-27 Official page ↗
Aliases
CVE-2025-52882
Ecosystem
npm
Packages
@anthropic-ai/claude-code
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
Weaknesses
CWE-1385, CWE-285
Reviewed
2025-06-23

Affected packages

• npm @anthropic-ai/claude-code: >= 0.2.116, < 1.0.24 → fixed in 1.0.24

Description

Claude Code extensions in VSCode and forks (e.g., Cursor, Windsurf, and VSCodium) and JetBrains IDEs (e.g., IntelliJ, Pycharm, and Android Studio) are vulnerable to unauthorized websocket connections from an attacker when visiting attacker-controlled webpages. Claude Code for VSCode IDE extensions versions 0.2.116 through 1.0.23 are vulnerable. For Jetbrains IDE plugins, Claude Code [beta] versions 0.1.1 through 0.1.8 are vulnerable. In VSCode (and forks), exploitation would allow an attacker to read arbitrary files, see the list of files open in the IDE, get selection and diagnostics events from the IDE, or execute code in limited situations where a user has an open Jupyter Notebook and accepts a malicious prompt. In JetBrains IDEs, an attacker could get selection events, a list of open files, and a list of syntax errors. Remediation We released a patch for this issue on June 13th, 2025. Although Claude Code auto-updates when you launch it and auto-updates the extensions, you should take the following steps (the exact steps depend on your IDE). VSCode, Cursor, Windsurf, VSCodium, and other VSCode forks Extension Name: Claude Code for VSCode Instructions: 1. Open the list of Extensions (View->Extensions) 2. Look for Claude Code for VSCode among installed extensions 3. If you have a version < 1.0.24, click “Update” (or “Uninstall”) 4. Restart the IDE All JetBrains IDEs including IntelliJ, PyCharm, and Android Studio Plugin name: Claude Code [Beta] Instructions: 1. Open the Plugins list 2. Look for Claude Code [Beta] among installed extensions 3. Update (or Uninstall) the plugin if the version is < 0.1.9 4. Restart the IDE

Related

Alias · CVE (1)

Weakness · CWE (2)

  • CWE-1385 Missing Origin Validation in WebSockets weakness
  • CWE-285 Improper Authorization weakness

References