GitHub Advisoryadvisory · Packagist
GHSA-9f8f-574q-8jmf Manipulation of product reviews via API
MEDIUM
Official page ↗
- Aliases
- CVE-2021-37707
- Ecosystem
- Packagist
- Packages
- shopware/platform, shopware/core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2021-08-26
Affected packages
• Packagist shopware/platform: < 6.4.3.1 → fixed in 6.4.3.1
• Packagist shopware/core: < 6.4.3.1 → fixed in 6.4.3.1
Description
Impact
Manipulation of product reviews via API
Patches
We recommend updating to the current version 6.4.3.1. You can get the update to 6.4.3.1 regularly via the Auto-Updater or directly via the download overview.
https://www.shopware.com/en/download/#shopware-6
Workarounds
For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659
Related
Alias · CVE (1)
- CVE-2021-37707 Shopware is an open source eCommerce platform. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness