GitHub Advisoryadvisory · Packagist

GHSA-9f9r-w3xq-f722 Croogo vulnerable to XSS in Blog field

MEDIUM Published 2022-05-14 Modified 2023-09-28 Official page ↗
Aliases
CVE-2019-7168
Ecosystem
Packagist
Packages
croogo/croogo
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-07-19

Affected packages

• Packagist croogo/croogo: < 3.0.7 → fixed in 3.0.7

Description

A stored-self XSS exists in Croogo through v3.0.5, allowing an attacker to execute HTML or JavaScript code in a vulnerable Blog field to `/admin/nodes/nodes/add/blog`.

Related

Alias · CVE (1)

  • CVE-2019-7168 A stored-self XSS exists in Croogo through v3.0.5, allowing an attacker to execute HTML or JavaScript code in a vulnerable Blog field to… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References