GitHub Advisoryadvisory · RubyGems

GHSA-9fh3-vh3h-q4g3 activesupport Cross-site Scripting vulnerability

MEDIUM Published 2017-10-24 Modified 2023-05-12 Official page ↗
Aliases
CVE-2011-2932
Ecosystem
RubyGems
Packages
activesupport
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems activesupport: >= 2.0.0, < 2.3.13 → fixed in 2.3.13 • RubyGems activesupport: >= 3.0.0, < 3.0.10 → fixed in 3.0.10

Description

Cross-site scripting (XSS) vulnerability in `activesupport/lib/active_support/core_ext/string/output_safety.r`b in Ruby on Rails 2.x before 2.3.13, 3.0.x before 3.0.10, and 3.1.x before 3.1.0.rc5 allows remote attackers to inject arbitrary web script or HTML via a malformed Unicode string, related to a "UTF-8 escaping vulnerability."

Related

Alias · CVE (1)

  • CVE-2011-2932 Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails 2.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References