GitHub Advisoryadvisory · npm

GHSA-9fjp-q3c4-6w3j Parse Server has a query condition depth bypass via pre-validation transform pipeline

HIGH Published 2026-03-20 Modified 2026-03-30 Official page ↗
Aliases
CVE-2026-33498
Ecosystem
npm
Packages
parse-server
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-674
Reviewed
2026-03-20

Affected packages

• npm parse-server: >= 9.0.0, < 9.6.0-alpha.44 → fixed in 9.6.0-alpha.44 • npm parse-server: < 8.6.55 → fixed in 8.6.55

Description

Impact An attacker can send an unauthenticated HTTP request with a deeply nested query containing logical operators to permanently hang the Parse Server process. The server becomes completely unresponsive and must be manually restarted. This is a bypass of the fix for CVE-2026-32944. Patches The query condition nesting depth is now validated before the query enters the transformation pipeline, preventing deeply nested structures from being recursively processed before the existing depth guard can fire. Workarounds None.

Related

Alias · CVE (1)

  • CVE-2026-33498 Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. vulnerability

Weakness · CWE (1)

  • CWE-674 Uncontrolled Recursion weakness

References