GitHub Advisoryadvisory · Go

GHSA-9fmc-5fq4-5jwh HashiCorp Nomad vulnerable to Insufficient Session Expiration

LOW Published 2022-11-10 Modified 2022-11-10 Official page ↗
Aliases
CVE-2022-3867
Ecosystem
Go
Packages
github.com/hashicorp/nomad
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-613
Reviewed
2022-11-10

Affected packages

• Go github.com/hashicorp/nomad: >= 1.4.0, < 1.4.2 → fixed in 1.4.2

Description

HashiCorp Nomad and Nomad Enterprise 1.4.0 up to 1.4.1 event stream subscribers using a token with TTL receive updates until token garbage is collected. Fixed in 1.4.2.

Related

Weakness · not in database (1)

Alias · CVE (1)

  • CVE-2022-3867 HashiCorp Nomad and Nomad Enterprise 1.4.0 up to 1.4.1 event stream subscribers using a token with TTL receive updates until token garbage… vulnerability

References