GitHub Advisoryadvisory · PyPI
GHSA-9fpg-838v-wpv7 TensorFlow vulnerable to `CHECK` fail in `FakeQuantWithMinMaxVars`
MEDIUM
Official page ↗
- Aliases
- CVE-2022-35971
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-cpu, tensorflow-gpu
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-617
- Reviewed
- 2022-09-16
Affected packages
• PyPI tensorflow: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
• PyPI tensorflow-cpu: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-cpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
• PyPI tensorflow-gpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
• PyPI tensorflow-gpu: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
Description
Impact
If `FakeQuantWithMinMaxVars` is given `min` or `max` tensors of a nonzero rank, it results in a `CHECK` fail that can be used to trigger a denial of service attack.
```python
import tensorflow as tf
num_bits = 8
narrow_range = False
inputs = tf.constant(0, shape=[2,3], dtype=tf.float32)
min = tf.constant(0, shape=[2,3], dtype=tf.float32)
max = tf.constant(0, shape=[2,3], dtype=tf.float32)
tf.raw_ops.FakeQuantWithMinMaxVars(inputs=inputs, min=min, max=max, num_bits=num_bits, narrow_range=narrow_range)
```
Patches
We have patched the issue in GitHub commit 785d67a78a1d533759fcd2f5e8d6ef778de849e0.
The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by:
• Neophytos Christou, Secure Systems Labs, Brown University.
• 刘力源, Information System & Security and Countermeasures Experiments Center, Beijing Institute of Technology
Related
Alias · CVE (1)
- CVE-2022-35971 TensorFlow is an open source platform for machine learning. vulnerability
Weakness · CWE (1)
- CWE-617 Reachable Assertion weakness
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9fpg-838v-wpv7 web
- https://nvd.nist.gov/vuln/detail/CVE-2022-35971 advisory
- https://github.com/tensorflow/tensorflow/commit/785d67a78a1d533759fcd2f5e8d6ef778de849e0 web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0 web