GitHub Advisoryadvisory · Go
GHSA-9fpw-c9x7-cv3j Mattermost allows remote actor to set arbitrary RemoteId values for synced users
MEDIUM
Official page ↗
- Aliases
- CVE-2024-41926
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-284, CWE-346
- Reviewed
- 2024-08-02
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 9.5.0, < 9.5.7 → fixed in 9.5.7
• Go github.com/mattermost/mattermost/server/v8: >= 9.9.0, < 9.9.1 → fixed in 9.9.1
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20240604093018-5114c3b7cdb8 → fixed in 8.0.0-20240604093018-5114c3b7cdb8
• Go github.com/mattermost/mattermost: < 5.3.2-0.20240604093018-5114c3b7cdb8 → fixed in 5.3.2-0.20240604093018-5114c3b7cdb8
Description
Mattermost versions 9.9.x <= 9.9.0 and 9.5.x <= 9.5.6 fail to validate the source of sync messages and only allow the correct remote IDs, which allows a malicious remote to set arbitrary RemoteId values for synced users and therefore claim that a user was synced from another remote.
Related
Alias · CVE (1)
- CVE-2024-41926 Mattermost versions 9.9.x <= 9.9.0 and 9.5.x <= 9.5.6 fail to validate the source of sync messages and only allow the correct remote IDs,… vulnerability