GitHub Advisoryadvisory · PyPI

GHSA-9g2w-5f3v-mfmm Insecure default config of Celery worker in Apache Airflow

CRITICAL Published 2020-07-27 Modified 2024-09-11 Official page ↗
Aliases
CVE-2020-11982
Ecosystem
PyPI
Packages
apache-airflow
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2020-07-27

Affected packages

• PyPI apache-airflow: < 1.10.11 → fixed in 1.10.11

Description

An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attack can connect to the broker (Redis, RabbitMQ) directly, it was possible to insert a malicious payload directly to the broker which could lead to a deserialization attack (and thus remote code execution) on the Worker.

Related

Alias · CVE (1)

  • CVE-2020-11982 An issue was found in Apache Airflow versions 1.10.10 and below. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References