GitHub Advisoryadvisory · npm
GHSA-9g4f-5rpg-4948 NodeBB Cross-site Scripting Vulnerability in Markdown Processing
MEDIUM
Official page ↗
- Aliases
- CVE-2015-3296
- Ecosystem
- npm
- Packages
- nodebb, nodebb-plugin-markdown
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-08-04
Affected packages
• npm nodebb: < 0.70 → fixed in 0.70
• npm nodebb-plugin-markdown: < 5.1.1 → fixed in 5.1.1
Description
Multiple cross-site scripting (XSS) vulnerabilities in NodeBB before 0.7 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) javascript: or (2) data: URLs.
Related
Alias · CVE (1)
- CVE-2015-3296 Multiple cross-site scripting (XSS) vulnerabilities in NodeBB before 0.7 allow remote attackers to inject arbitrary web script or HTML via… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-3296 advisory
- https://github.com/NodeBB/NodeBB/issues/2273 web
- https://github.com/NodeBB/nodebb-plugin-markdown/commit/ab7f2684750882f7baefbfa31db8d5aac71e6ec3 web
- https://github.com/markdown-it/markdown-it/commit/f76d3beb46abd121892a2e2e5c78376354c214e3 web
- https://web.archive.org/web/20200228230630/http://www.securityfocus.com/bid/71824 web
- http://www.openwall.com/lists/oss-security/2015/04/10/10 web