GitHub Advisoryadvisory · Maven
GHSA-9ggw-87m9-9gfc Spring Web Flow has Data Binding Vulnerability with Unified EL Parser
MEDIUM
Official page ↗
- Aliases
- CVE-2026-40985
- Ecosystem
- Maven
- Packages
- org.springframework.webflow:spring-webflow
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-917
- Reviewed
- 2026-08-18
Affected packages
• Maven org.springframework.webflow:spring-webflow: >= 4.0.0, < 4.0.1 → fixed in 4.0.1
• Maven org.springframework.webflow:spring-webflow: >= 3.0.0, < 3.0.2 → fixed in 3.0.2
• Maven org.springframework.webflow:spring-webflow: <= 2.5.1 (no fix yet)
Description
Applications that configure the WebFlowELExpressionParser are vulnerable to the use of malicious Unified EL expressions.
Affected versions:
Spring Web Flow 4.0.0; 3.0.0 through 3.0.1; 2.5.0 through 2.5.1.
Related
Alias · CVE (1)
- CVE-2026-40985 Applications that configure the WebFlowELExpressionParser are vulnerable to the use of malicious Unified EL expressions. vulnerability
Weakness · CWE (1)
- CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement weakness