GitHub Advisoryadvisory · npm

GHSA-9gh8-wp53-ccc6 ghost vulnerable to unauthorized newsletter modification via improper access controls

HIGH Published 2022-11-28 Modified 2022-12-30 Official page ↗
Aliases
CVE-2022-41654
Ecosystem
npm
Packages
ghost
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N
Weaknesses
CWE-284
Reviewed
2022-11-28

Affected packages

• npm ghost: >= 5.0.0, < 5.22.7 → fixed in 5.22.7 • npm ghost: >= 4.46.0, < 4.48.8 → fixed in 4.48.8

Description

Impact On sites where members is enabled (this is the default) it is possible for members (unprivileged users) to make changes to newsletter settings. This gives unprivileged users the ability to view and change settings they were not intended to have access to. They are not able to escalate their privileges permanently or get access to further information. This issue was caused by a gap in our API validation for nested objects. Ghost(Pro) has already been patched. We can find no evidence that the issue was exploited on Ghost(Pro) prior to the patch being added. Self-hosters are impacted if running Ghost a version between v4.46.0 and v4.48.7 or any version of v5 prior to v5.22.7. Immediate action should be taken to secure your site - see patches & workarounds below. Patches • v4.48.8 / v5.22.7 are patched for all known exploits. • v4.48.9 / v5.24.1 contain deeper fixes to the API to close the potential for this vulnerability to appear elsewhere or regress Workarounds The known exploit can be prevented by disabling members until an update can be performed. References • forum post For more information If you have any questions or comments about this advisory: • Email us at [email protected] --- Credits: Dave McDaniel and other members of Cisco Talos

Related

Alias · CVE (1)

  • CVE-2022-41654 An authentication bypass vulnerability exists in the newsletter subscription functionality of Ghost Foundation Ghost 5.9.4. vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References