GitHub Advisoryadvisory · Maven

GHSA-9gp7-jvm2-r4mx Apache Struts Improper Input Validation vulnerability

MEDIUM Published 2018-10-16 Modified 2024-01-04 Official page ↗
Aliases
CVE-2017-7672
Ecosystem
Maven
Packages
org.apache.struts:struts2-core
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• Maven org.apache.struts:struts2-core: >= 2.5.0, < 2.5.12 → fixed in 2.5.12

Description

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

Related

Alias · CVE (1)

  • CVE-2017-7672 If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References