GitHub Advisoryadvisory · PyPI
GHSA-9gqg-3fxr-9hv7 Apache Airflow vulnerable to XSS
CRITICAL
Official page ↗
- Aliases
- CVE-2017-17836
- Ecosystem
- PyPI
- Packages
- apache-airflow
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• PyPI apache-airflow: < 1.9.0 → fixed in 1.9.0
Description
In Apache Airflow 1.8.2 and earlier, an experimental Airflow feature displayed authenticated cookies, as well as passwords to databases used by Airflow. An attacker who has limited access to airflow, weather it be via XSS or by leaving a machine unlocked can exfil all credentials from the system.
Related
Alias · CVE (1)
- CVE-2017-17836 In Apache Airflow 1.8.2 and earlier, an experimental Airflow feature displayed authenticated cookies, as well as passwords to databases… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-17836 advisory
- https://github.com/advisories/GHSA-9gqg-3fxr-9hv7 advisory
- https://github.com/apache/airflow package
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2019-149.yaml web
- https://lists.apache.org/thread.html/ade4d54ebf614f68dc81a08891755e60ea58ba88e0209233eeea5f57@%3Cdev.airflow.apache.org%3E web