GitHub Advisoryadvisory · PyPI
GHSA-9gxx-32p7-ff7m Modoboa has Weak Password Requirements
MEDIUM
Official page ↗
- Aliases
- CVE-2023-2160
- Ecosystem
- PyPI
- Packages
- modoboa
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-521
- Reviewed
- 2023-04-21
Affected packages
• PyPI modoboa: < 2.1.0 → fixed in 2.1.0
Description
Modoboa 2.0.5 and prior allows users to set unsafe passwords, such as `1` or `HACK`. This issue is fixed in commit 130257c96a2392ada795785a91178e656e27015c and is part of version 2.1.0.
Related
Alias · CVE (1)
- CVE-2023-2160 Weak Password Requirements in GitHub repository modoboa/modoboa prior to 2.1.0. vulnerability
Weakness · CWE (1)
- CWE-521 Weak Password Requirements weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-2160 advisory
- https://github.com/modoboa/modoboa/commit/130257c96a2392ada795785a91178e656e27015c web
- https://github.com/modoboa/modoboa package
- https://github.com/pypa/advisory-database/tree/main/vulns/modoboa/PYSEC-2023-34.yaml web
- https://huntr.dev/bounties/54fb6d6a-6b39-45b6-b62a-930260ba484b web