GitHub Advisoryadvisory · RubyGems

GHSA-9h6g-gp95-x3q5 actionpack is vulnerable to denial of service because of a wildcard controller route

HIGH Published 2017-10-24 Modified 2022-04-25 Official page ↗
Aliases
CVE-2015-7581
Ecosystem
RubyGems
Packages
actionpack
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: >= 4.0.0, < 4.2.5.1 → fixed in 4.2.5.1

Description

actionpack/lib/action_dispatch/routing/route_set.rb in Action Pack in Ruby on Rails 4.x before 4.2.5.1 and 5.x before 5.0.0.beta1.1 allows remote attackers to cause a denial of service (superfluous caching and memory consumption) by leveraging an application's use of a wildcard controller route.

Related

Alias · CVE (1)

  • CVE-2015-7581 actionpack/lib/action_dispatch/routing/route_set.rb in Action Pack in Ruby on Rails 4.x before 4.2.5.1 and 5.x before 5.0.0.beta1.1 allows… vulnerability

References