GitHub Advisoryadvisory · Go
GHSA-9h6j-4ffx-cm84 Mattermost doesn't restrict domains LLM can request to contact upstream
LOW
Official page ↗
- Aliases
- CVE-2025-31363
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
- Weaknesses
- CWE-201, CWE-497
- Reviewed
- 2025-04-16
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 10.5.0, < 10.5.1 → fixed in 10.5.1
• Go github.com/mattermost/mattermost/server/v8: >= 10.4.0, < 10.4.3 → fixed in 10.4.3
• Go github.com/mattermost/mattermost/server/v8: >= 9.11.0, < 9.11.10 → fixed in 9.11.10
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250218121836-2b5275d87136 → fixed in 8.0.0-20250218121836-2b5275d87136
Description
Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.9 fail to restrict domains the LLM can request to contact upstream which allows an authenticated user to exfiltrate data from an arbitrary server accessible to the victim via performing a prompt injection in the AI plugin's Jira tool.
Related
Alias · CVE (1)
- CVE-2025-31363 Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.9 fail to restrict domains the LLM can request to contact upstream… vulnerability