GitHub Advisoryadvisory · PyPI
GHSA-9hcf-v7m4-6m2j vLLM allows clients to crash the openai server with invalid regex
MEDIUM
Official page ↗
- Aliases
- CVE-2025-48943
- Ecosystem
- PyPI
- Packages
- vllm
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-248
- Reviewed
- 2025-05-28
Affected packages
• PyPI vllm: >= 0.8.0, < 0.9.0 → fixed in 0.9.0
Description
Impact
A denial of service bug caused the vLLM server to crash if an invalid regex was provided while using structured output. This vulnerability is similar to GHSA-6qc9-v4r8-22xg, but for regex instead of a JSON schema.
Issue with more details: https://github.com/vllm-project/vllm/issues/17313
Patches
• https://github.com/vllm-project/vllm/pull/17623
Related
Alias · CVE (1)
- CVE-2025-48943 vLLM is an inference and serving engine for large language models (LLMs). vulnerability
Weakness · CWE (1)
- CWE-248 Uncaught Exception weakness
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-9hcf-v7m4-6m2j web
- https://nvd.nist.gov/vuln/detail/CVE-2025-48943 advisory
- https://github.com/vllm-project/vllm/issues/17313 web
- https://github.com/vllm-project/vllm/pull/17623 web
- https://github.com/vllm-project/vllm/commit/08bf7840780980c7568c573c70a6a8db94fd45ff web
- https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2025-55.yaml web
- https://github.com/vllm-project/vllm package