GitHub Advisoryadvisory · npm, NuGet, Packagist, PyPI
GHSA-9hcv-j9pv-qmph TinyMCE Cross-Site Scripting (XSS) vulnerability using noneditable_regexp option
MEDIUM
Official page ↗
- Aliases
- CVE-2024-38356
- Ecosystem
- npm, NuGet, Packagist, PyPI
- Packages
- tinymce, TinyMCE, tinymce/tinymce, django-tinymce
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-06-19
Affected packages
• npm tinymce: < 5.11.0 → fixed in 5.11.0
• NuGet TinyMCE: < 5.11.0 → fixed in 5.11.0
• Packagist tinymce/tinymce: < 5.11.0 → fixed in 5.11.0
• npm tinymce: >= 6.0.0, < 6.8.4 → fixed in 6.8.4
• npm tinymce: >= 7.0.0, < 7.2.0 → fixed in 7.2.0
• NuGet TinyMCE: >= 6.0.0, < 6.8.4 → fixed in 6.8.4
• NuGet TinyMCE: >= 7.0.0, < 7.2.0 → fixed in 7.2.0
• Packagist tinymce/tinymce: >= 6.0.0, < 6.8.4 → fixed in 6.8.4
• Packagist tinymce/tinymce: >= 7.0.0, < 7.2.0 → fixed in 7.2.0
• PyPI django-tinymce: < 4.1.0 → fixed in 4.1.0
Description
Impact
A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content extraction code. When using the `noneditable_regexp` option, specially crafted HTML attributes containing malicious code were able to be executed when content was extracted from the editor.
Patches
This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that, when using the `noneditable_regexp` option, any content within an attribute is properly verified to match the configured regular expression before being added.
Fix
To avoid this vulnerability:
• Upgrade to TinyMCE 7.2.0 or higher.
• Upgrade to TinyMCE 6.8.4 or higher for TinyMCE 6.x.
• Upgrade to TinyMCE 5.11.0 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract).
References
• TinyMCE 6.8.4
• TinyMCE 7.2.0
For more information
If you have any questions or comments about this advisory:
• Email us at [email protected]
• Open an issue in the TinyMCE repo
Related
Alias · CVE (1)
- CVE-2024-38356 TinyMCE is an open source rich text editor. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/tinymce/tinymce/security/advisories/GHSA-9hcv-j9pv-qmph web
- https://nvd.nist.gov/vuln/detail/CVE-2024-38356 advisory
- https://github.com/tinymce/tinymce/commit/5acb741665a98e83d62b91713c800abbff43b00d web
- https://github.com/tinymce/tinymce/commit/a9fb858509f86dacfa8b01cfd34653b408983ac0 web
- https://github.com/tinymce/tinymce package
- https://owasp.org/www-community/attacks/xss web
- https://www.tiny.cloud/docs/tinymce/6/6.8.4-release-notes/#overview web
- https://www.tiny.cloud/docs/tinymce/7/7.2-release-notes/#overview web
- https://www.tiny.cloud/docs/tinymce/latest/7.2-release-notes/#overview web