GitHub Advisoryadvisory · npm
GHSA-9hfw-cvf4-5x25 wangEditor was discovered to contain a cross-site scripting (XSS) vulnerability via the image upload function
MEDIUM
Official page ↗
- Aliases
- CVE-2022-25037
- Ecosystem
- npm
- Packages
- @wangeditor/editor
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Reviewed
- 2024-06-02
Affected packages
• npm @wangeditor/editor: < 4.7.12 → fixed in 4.7.12
Description
There is a cross-site scripting (XSS) issue in wangEditor via the image upload function in version 4.7.11. This issue has been fixed in version 4.7.12.
Related
Alias · CVE (1)
- CVE-2022-25037 An issue in wanEditor v4.7.11 and fixed in v.4.7.12 and v.5 was discovered to contain a cross-site scripting (XSS) vulnerability via the… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-25037 advisory
- https://github.com/wangeditor-team/wangEditor/issues/3870 web
- https://github.com/wangeditor-team/wangEditor/issues/3872 web
- https://github.com/wangeditor-team/wangEditor/commit/6257a2e166346913c34ac5cfb31b6a46e9544c5a web
- https://gist.github.com/Mdxjj/5cf0a31e8abf24ed688ceb5b3543516d web
- https://github.com/wangeditor-team/wangEditor package