GitHub Advisoryadvisory · Maven
GHSA-9hg7-xmf8-jxf9 Stored XSS vulnerability in Jenkins Liquibase Runner Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2020-2283
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:liquibase-runner
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-19
Affected packages
• Maven org.jenkins-ci.plugins:liquibase-runner: < 1.4.6 → fixed in 1.4.6
Description
Liquibase Runner Plugin 1.4.5 and earlier does not escape changeset contents when showing them on the build page.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide Liquibase changesets evaluated by the plugin.
Liquibase Runner Plugin 1.4.7 no longer supports evaluating changesets.
Related
Alias · CVE (1)
- CVE-2020-2283 Jenkins Liquibase Runner Plugin 1.4.5 and earlier does not escape changeset contents, resulting in a stored cross-site scripting (XSS)… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2283 advisory
- https://github.com/jenkinsci/liquibase-runner-plugin/commit/4873c19dc921653d994edd6caa9e161c6353c6ae web
- https://github.com/jenkinsci/liquibase-runner-plugin package
- https://www.jenkins.io/security/advisory/2020-09-23/#SECURITY-1885 web
- http://www.openwall.com/lists/oss-security/2020/09/23/1 web