GitHub Advisoryadvisory · Packagist

GHSA-9hh2-8cw6-hfv7 TYPO3 Cross-Site Scripting vulnerability in the Install Tool

LOW Published 2022-05-17 Modified 2024-02-07 Official page ↗
Aliases
CVE-2010-5100
Ecosystem
Packagist
Packages
typo3/cms-install
Severity
Low
Weaknesses
CWE-79
Reviewed
2024-02-07

Affected packages

• Packagist typo3/cms-install: >= 4.2.0, < 4.2.16 → fixed in 4.2.16 • Packagist typo3/cms-install: >= 4.3.0, < 4.3.9 → fixed in 4.3.9 • Packagist typo3/cms-install: >= 4.4.0, < 4.4.5 → fixed in 4.4.5

Description

Multiple cross-site scripting (XSS) vulnerabilities in the Install Tool in TYPO3 4.2.x before 4.2.16, 4.3.x before 4.3.9, and 4.4.x before 4.4.5 allow remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2010-5100 Multiple cross-site scripting (XSS) vulnerabilities in the Install Tool in TYPO3 4.2.x before 4.2.16, 4.3.x before 4.3.9, and 4.4.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References