GitHub Advisoryadvisory · RubyGems

GHSA-9hmq-fm33-x4xx Resque Scheduler Reflected XSS In Delayed Jobs View

MEDIUM Published 2023-12-18 Modified 2023-12-18 Official page ↗
Aliases
CVE-2022-44303
Ecosystem
RubyGems
Packages
resque-scheduler
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N
Weaknesses
CWE-79
Reviewed
2023-12-18

Affected packages

• RubyGems resque-scheduler: >= 1.27.4, < 4.10.2 → fixed in 4.10.2

Description

Impact Resque Scheduler version 1.27.4 and above are affected by a cross-site scripting vulnerability. A remote attacker can inject javascript code to the "{schedule_job}" or "args" parameter in /resque/delayed/jobs/{schedule_job}?args={args_id} to execute javascript at client side. Patches Fixed in v4.10.2 Workarounds No known workarounds at this time. It is recommended to not click on 3rd party or untrusted links to the resque-web interface until you have patched your application. References • https://nvd.nist.gov/vuln/detail/CVE-2022-44303 • https://github.com/resque/resque-scheduler/issues/761 • https://github.com/resque/resque/issues/1885 • https://github.com/resque/resque-scheduler/pull/780 • https://github.com/resque/resque-scheduler/pull/783

Related

Alias · CVE (1)

  • CVE-2022-44303 Resque Scheduler version 1.27.4 is vulnerable to Cross-site scripting (XSS). vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References