GitHub Advisoryadvisory · Maven

GHSA-9hr6-5x6g-gg5g Jenkins allows Cross-Site Scripting (XSS)

LOW Published 2022-05-14 Modified 2025-03-13 Official page ↗
Aliases
CVE-2012-6074
Ecosystem
Maven
Packages
org.jenkins-ci.main:jenkins-core
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-79
Reviewed
2025-03-13

Affected packages

• Maven org.jenkins-ci.main:jenkins-core: >= 1.481, < 1.491 → fixed in 1.491 • Maven org.jenkins-ci.main:jenkins-core: < 1.480.1 → fixed in 1.480.1

Description

Cross-site scripting (XSS) vulnerability in Jenkins before 1.491, Jenkins LTS before 1.480.1, and Jenkins Enterprise 1.424.x before 1.424.6.13, 1.447.x before 1.447.4.1, and 1.466.x before 1.466.10.1 allows remote authenticated users with write access to inject arbitrary web script or HTML via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2012-6074 Cross-site scripting (XSS) vulnerability in Jenkins before 1.491, Jenkins LTS before 1.480.1, and Jenkins Enterprise 1.424.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References