GitHub Advisoryadvisory · Packagist

GHSA-9hw3-4gvp-8mv5 TYPO3 Cross-site scripting (XSS) vulnerability in the click enlarge functionality

LOW Published 2022-05-17 Modified 2024-02-07 Official page ↗
Aliases
CVE-2010-5097
Ecosystem
Packagist
Packages
typo3/cms-frontend
Severity
Low
Weaknesses
CWE-79
Reviewed
2024-02-07

Affected packages

• Packagist typo3/cms-frontend: >= 4.3.0, < 4.3.9 → fixed in 4.3.9 • Packagist typo3/cms-frontend: >= 4.4.0, < 4.4.5 → fixed in 4.4.5

Description

Cross-site scripting (XSS) vulnerability in the click enlarge functionality in TYPO3 4.3.x before 4.3.9 and 4.4.x before 4.4.5 when the caching framework is enabled, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2010-5097 Cross-site scripting (XSS) vulnerability in the click enlarge functionality in TYPO3 4.3.x before 4.3.9 and 4.4.x before 4.4.5 when the… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References