GitHub Advisoryadvisory · Packagist
GHSA-9j2p-8qqf-h55c Cross-site Scripting in UDX Stateless Media Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-4905
- Ecosystem
- Packagist
- Packages
- wpcloud/wp-stateless
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-02-23
Affected packages
• Packagist wpcloud/wp-stateless: < 3.2.0 → fixed in 3.2.0
Description
A vulnerability was found in UDX Stateless Media Plugin 3.1.1. It has been declared as problematic. This vulnerability affects the function setup_wizard_interface of the file lib/classes/class-settings.php. The manipulation of the argument settings leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 3.2.0 is able to address this issue. The name of the patch is 6aee7ae0b0beeb2232ce6e1c82aa7e2041ae151a. It is recommended to upgrade the affected component. VDB-220750 is the identifier assigned to this vulnerability.
Related
Alias · CVE (1)
- CVE-2022-4905 A vulnerability was found in UDX Stateless Media Plugin 3.1.1 on WordPress. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-4905 advisory
- https://github.com/udx/wp-stateless/pull/630 web
- https://github.com/udx/wp-stateless/commit/6aee7ae0b0beeb2232ce6e1c82aa7e2041ae151a web
- https://github.com/udx/wp-stateless package
- https://github.com/udx/wp-stateless/releases/tag/3.2.0 web
- https://vuldb.com/?ctiid.220750 web
- https://vuldb.com/?id.220750 web