GitHub Advisoryadvisory · npm

GHSA-9j49-mfvp-vmhm Code Injection in pac-resolver

HIGH Published 2021-09-02 Modified 2021-08-25 Official page ↗
Aliases
CVE-2021-23406
Ecosystem
npm
Packages
pac-resolver, degenerator
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2021-08-25

Affected packages

• npm pac-resolver: < 5.0.0 → fixed in 5.0.0 • npm degenerator: < 3.0.1 → fixed in 3.0.1

Description

This affects the package pac-resolver before 5.0.0. This can occur when used with untrusted input, due to unsafe PAC file handling. NOTE: The fix for this vulnerability is applied in the node-degenerator library, a dependency written by the same maintainer.

Related

Alias · CVE (1)

  • CVE-2021-23406 This affects the package pac-resolver before 5.0.0. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References