GitHub Advisoryadvisory · RubyGems

GHSA-9j7m-rjqx-48vh RubyGems Regular Expression Denial of Service vulnerability

MEDIUM Published 2022-05-14 Modified 2023-03-08 Official page ↗
Aliases
CVE-2013-4287
Ecosystem
RubyGems
Packages
rubygems-update
Severity
Moderate
Weaknesses
CWE-400
Reviewed
2023-03-08

Affected packages

• RubyGems rubygems-update: < 1.8.23.1 → fixed in 1.8.23.1 • RubyGems rubygems-update: >= 1.8.24, < 1.8.26 → fixed in 1.8.26 • RubyGems rubygems-update: >= 2.0.0, < 2.0.8 → fixed in 2.0.8 • RubyGems rubygems-update: >= 2.1.0.rc.1, < 2.1.0 → fixed in 2.1.0

Description

Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in `lib/rubygems/version.rb` in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.

Related

Alias · CVE (1)

  • CVE-2013-4287 Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References