GitHub Advisoryadvisory · Packagist

GHSA-9j9h-cpgc-8356 phpMyAdmin vulnerable to Cross-site Scripting

LOW Published 2022-05-17 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-4634
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:U
Weaknesses
CWE-79
Reviewed
2025-04-12

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 3.4.0, < 3.4.8 → fixed in 3.4.8

Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.8 allow remote attackers to inject arbitrary web script or HTML via (1) a crafted database name, related to the Database Synchronize panel; (2) a crafted database name, related to the Database rename panel; (3) a crafted SQL query, related to the table overview panel; (4) a crafted SQL query, related to the view creation dialog; (5) a crafted column type, related to the table search dialog; or (6) a crafted column type, related to the create index dialog.

Related

Alias · CVE (1)

  • CVE-2011-4634 Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.8 allow remote attackers to inject arbitrary web script… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References