GitHub Advisoryadvisory · Packagist
GHSA-9jf6-wq34-fg9w Moodle XSS Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2019-14881
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-18
Affected packages
• Packagist moodle/moodle: >= 3.7.0, < 3.7.3 → fixed in 3.7.3
Description
A vulnerability was found in moodle 3.7 to 3.7.2 and before 3.7.3, where there is blind XSS reflected in some locations where user email is displayed.
Related
Alias · CVE (1)
- CVE-2019-14881 A vulnerability was found in moodle 3.7 before 3.7.3, where there is blind XSS reflected in some locations where user email is displayed. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-14881 advisory
- https://github.com/moodle/moodle/commit/7455b741c954af3c3e7dfda2972edc1146ea1562 web
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14881 web
- https://github.com/moodle/moodle package
- https://moodle.org/mod/forum/discuss.php?d=393584#p1586746 web