GitHub Advisoryadvisory · PyPI

GHSA-9jxq-5x44-gx23 Keylime registrar is vulnerable to Denial-of-Service attack when updated to version 7.12.0

MEDIUM Published 2025-02-14 Modified 2026-07-21 Official page ↗
Aliases
CVE-2025-1057
Ecosystem
PyPI
Packages
keylime
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Weaknesses
CWE-1287, CWE-704
Reviewed
2025-02-14

Affected packages

• PyPI keylime: >= 7.12.0, < 7.12.1 → fixed in 7.12.1

Description

Impact The Keylime `registrar` implemented more strict type checking on version 7.12.0. As a result, when updated to version 7.12.0, the `registrar` will not accept the format of the data previously stored in the database by versions >= 7.8.0, raising an exception. This makes the Keylime `registrar` vulnerable to a Denial-of-Service attack in an update scenario, as an attacker could populate the `registrar` database by creating multiple valid agent registrations with different UUIDs while the version is still = 7.12.1 Workarounds • Remove the registrar database and re-register all agents Credit Reported by: Anderson Toshiyuki Sasaki/@ansasaki Patched by: Anderson Toshiyuki Sasaki/@ansasaki

Related

Alias · CVE (1)

  • CVE-2025-1057 A flaw was found in Keylime, a remote attestation solution, where strict type checking introduced in version 7.12.0 prevents the registrar… vulnerability

Weakness · CWE (2)

  • CWE-1287 Improper Validation of Specified Type of Input weakness
  • CWE-704 Incorrect Type Conversion or Cast weakness

References