GitHub Advisoryadvisory · RubyGems
GHSA-9m3q-rhmv-5q44 Out-of-bounds Read in Ruby JSON Parser
HIGH
Official page ↗
- Aliases
- CVE-2025-27788
- Ecosystem
- RubyGems
- Packages
- json
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-125
- Reviewed
- 2025-03-12
Affected packages
• RubyGems json: >= 2.10.0, < 2.10.2 → fixed in 2.10.2
Description
Impact
A specially crafted document could cause an out of bound read, most likely resulting in a crash.
Versions 2.10.0 and 2.10.1 are impacted. Older versions are not.
Patches
Version 2.10.2 fixes the problem.
Workarounds
None.
Related
Alias · CVE (1)
- CVE-2025-27788 JSON is a JSON implementation for Ruby. vulnerability
Weakness · CWE (1)
- CWE-125 Out-of-bounds Read weakness
References
- https://github.com/ruby/json/security/advisories/GHSA-9m3q-rhmv-5q44 web
- https://nvd.nist.gov/vuln/detail/CVE-2025-27788 advisory
- https://github.com/ruby/json/commit/c56db31f800d5d508389793e69682f99749dbadf web
- https://github.com/ruby/json package
- https://github.com/ruby/json/releases/tag/v2.10.2 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/json/CVE-2025-27788.yml web