GitHub Advisoryadvisory · Packagist

GHSA-9mh6-g99m-ppcw auth0-PHP SDK Does Not Properly Handle File Types in Bulk User Import

LOW Published 2025-10-01 Modified 2025-10-01 Official page ↗
Aliases
CVE-2025-58769
Ecosystem
Packagist
Packages
auth0/auth0-php
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-22, CWE-434
Reviewed
2025-10-01

Affected packages

• Packagist auth0/auth0-php: >= 3.3.0, < 8.17.0 → fixed in 8.17.0

Description

Overview In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. Am I affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0-PHP SDK, versions between v3.3.0 and v8.16.0, or 2. Applications using the following SDKs that rely on the Auth0-PHP SDK versions between v3.3.0 and v8.16.0: a. Auth0/symfony, b. Auth0/laravel-auth0, c. Auth0/wordpress. Fix Upgrade Auth0/Auth0-PHP to version 8.17.0 or greater. Acknowledgement Okta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.

Related

Alias · CVE (1)

  • CVE-2025-58769 auth0-PHP is an SDK for Auth0 Authentication and Management APIs. vulnerability

Weakness · CWE (2)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
  • CWE-434 Unrestricted Upload of File with Dangerous Type weakness

References