GitHub Advisoryadvisory · PyPI

GHSA-9mq4-9556-6qxq NYUCCL psiTurk IS vulnerable to Improper Neutralization of Special Elements

HIGH Published 2023-01-29 Modified 2024-10-18 Official page ↗
Aliases
CVE-2021-4315
Ecosystem
PyPI
Packages
psiTurk
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-1336, CWE-94
Reviewed
2023-01-31

Affected packages

• PyPI psiTurk: < 3.2.1 → fixed in 3.2.1

Description

A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.

Related

Alias · CVE (1)

  • CVE-2021-4315 A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. vulnerability

Weakness · CWE (2)

  • CWE-1336 Improper Neutralization of Special Elements Used in a Template Engine weakness
  • CWE-94 Improper Control of Generation of Code weakness

References