GitHub Advisoryadvisory · npm

GHSA-9p2w-rmx4-9mw7 Command Injection in strapi

HIGH Published 2020-09-04 Modified 2025-12-29 Official page ↗
Aliases
CVE-2019-19609
Ecosystem
npm
Packages
strapi
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2020-08-31

Affected packages

• npm strapi: < 3.0.0-beta.17.8 → fixed in 3.0.0-beta.17.8

Description

Versions of `strapi` before 3.0.0-beta.17.8 are vulnerable to Command Injection. The package fails to sanitize plugin names in the `/admin/plugins/install/` route. This may allow an authenticated attacker with admin privileges to run arbitrary commands in the server. Recommendation Upgrade to version 3.0.0-beta.17.8 or later

Related

Alias · CVE (1)

  • CVE-2019-19609 The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the… vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References