GitHub Advisoryadvisory · Packagist
GHSA-9p3p-w5jf-8xxg Kirby vulnerable to path traversal in the router for PHP's built-in server
LOW
Official page ↗
- Aliases
- CVE-2025-30207
- Ecosystem
- Packagist
- Packages
- getkirby/cms
- Severity
- Low
- CVSS vector
- CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N
- Weaknesses
- CWE-22, CWE-23
- Reviewed
- 2025-05-13
Affected packages
• Packagist getkirby/cms: < 3.9.8.3 → fixed in 3.9.8.3
• Packagist getkirby/cms: >= 3.10.0, < 3.10.1.2 → fixed in 3.10.1.2
• Packagist getkirby/cms: >= 4.0.0, < 4.7.1 → fixed in 4.7.1
Description
TL;DR
This vulnerability affects all Kirby setups that use PHP's built-in server. Such setups are commonly only used during local development.
Sites that use other server software (such as Apache, nginx or Caddy) are *not* affected.
----
Introduction
For use with PHP's built-in web server, Kirby provides a `router.php` file. The router delegates requests to static files to PHP so that assets and other static files in the document root can be accessed by the browser.
This logic was vulnerable against path traversal attacks. By using special elements such as `..` and `/` separators, attackers can escape outside of the restricted location to access files or directories that are elsewhere on the system. One of the most common special elements is the `../` sequence, which in most modern operating systems is interpreted as the parent directory of the current location.
Impact
The missing path traversal check allowed attackers to navigate all files on the server that were accessible to the PHP process, including files outside of the Kirby installation.
The vulnerable implementation delegated all existing files to PHP, including existing files outside of the document root. This leads to a different response that allows attackers to determine whether the requested file exists.
Because Kirby's router only delegates such requests to PHP and does not load or execute them, contents of the files were not exposed as PHP treats requests to files outside of the document root as invalid.
Patches
The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2 and Kirby 4.7.1. Please update to one of these or a later version to fix the vulnerability.
In all of the mentioned releases, we have updated the router to check if existing static files are within the document root. Requests to files outside the document root are treated as page requests of the error page and will no longer allow to determine whether the file exists or not.
Related
Alias · CVE (1)
- CVE-2025-30207 Kirby is an open-source content management system. vulnerability
References
- https://github.com/getkirby/kirby/security/advisories/GHSA-9p3p-w5jf-8xxg web
- https://nvd.nist.gov/vuln/detail/CVE-2025-30207 advisory
- https://github.com/getkirby/kirby/commit/3ebc9ad3f5adcbd4838ce60219f1c9a561231235 web
- https://github.com/getkirby/kirby package
- https://github.com/getkirby/kirby/releases/tag/3.10.1.2 web
- https://github.com/getkirby/kirby/releases/tag/3.9.8.3 web
- https://github.com/getkirby/kirby/releases/tag/4.7.1 web