GitHub Advisoryadvisory · RubyGems

GHSA-9p3v-wf2w-v29c Moderate severity vulnerability that affects rails

MEDIUM Published 2017-10-24 Modified 2025-04-09 Official page ↗
Aliases
CVE-2009-4214
Ecosystem
RubyGems
Packages
rails
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems rails: < 2.2.2 → fixed in 2.2.2 • RubyGems rails: >= 2.3.0, < 2.3.5 → fixed in 2.3.5

Description

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Related

Alias · CVE (1)

  • CVE-2009-4214 Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References