GitHub Advisoryadvisory · Maven

GHSA-9p56-p6mw-w8qc Jenkins has a Denial of service vulnerability in HTTP-based CLI

HIGH Published 2025-12-10 Modified 2026-01-22 Official page ↗
Aliases
CVE-2025-67635
Ecosystem
Maven
Packages
org.jenkins-ci.main:jenkins-core, org.jenkins-ci.main:cli
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-404
Reviewed
2025-12-10

Affected packages

• Maven org.jenkins-ci.main:jenkins-core: >= 2.529, < 2.541 → fixed in 2.541 • Maven org.jenkins-ci.main:cli: >= 2.529, < 2.541 → fixed in 2.541 • Maven org.jenkins-ci.main:jenkins-core: < 2.528.3 → fixed in 2.528.3 • Maven org.jenkins-ci.main:cli: < 2.528.3 → fixed in 2.528.3

Description

Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.

Related

Alias · CVE (1)

  • CVE-2025-67635 Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes… vulnerability

Weakness · CWE (1)

  • CWE-404 Improper Resource Shutdown or Release weakness

References