GitHub Advisoryadvisory · Go
GHSA-9p64-jpc7-m2rp Mattermost doesn't sanitize sensitive configuration fields before including them in support packet generation
HIGH
Official page ↗
- Aliases
- CVE-2026-6346
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2026-06-01
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 11.5.0, < 11.5.2 → fixed in 11.5.2
• Go github.com/mattermost/mattermost/server/v8: >= 10.11.0, < 10.11.14 → fixed in 10.11.14
• Go github.com/mattermost/mattermost/server/v8: >= 11.4.0, < 11.4.4 → fixed in 11.4.4
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20260326202606-fac92f4a71f3 → fixed in 8.0.0-20260326202606-fac92f4a71f3
• Go github.com/mattermost/mattermost-server: < 5.3.2-0.20260326202606-fac92f4a71f3 → fixed in 5.3.2-0.20260326202606-fac92f4a71f3
Description
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to sanitize sensitive configuration fields before including them in support packet generation, which allows a Mattermost System Admin or any party with access to a support packet to obtain sensitive credentials in plaintext via downloading a support packet from the System Console.. Mattermost Advisory ID: MMSA-2026-00607
Related
Alias · CVE (1)
- CVE-2026-6346 Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to sanitize sensitive configuration fields before… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness