GitHub Advisoryadvisory · Packagist

GHSA-9p7c-v5x3-rfx8 Craft CMS: Missing authorization check allows non-admin control panel users to reorder Global Sets

MEDIUM Published 2026-08-06 Modified 2026-08-06 Official page ↗
Aliases
CVE-2026-14793
Ecosystem
Packagist
Packages
craftcms/cms
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-862
Reviewed
2026-08-06

Affected packages

• Packagist craftcms/cms: >= 4.0.0-RC1, < 4.18.1 → fixed in 4.18.1 • Packagist craftcms/cms: >= 5.0.0-RC1, < 5.10.3 → fixed in 5.10.3

Description

The `reorder-sets` action in Craft CMS’s `GlobalsController` is missing the `requireAdmin()` check that the adjacent `save-set` and `delete-set` actions both enforce. Any authenticated control panel user can POST to `/actions/globals/reorder-sets` and permanently reorder all global sets in the project config, regardless of whether they have admin access. The reordering is written through to the project config and persists across requests. Description `GlobalsController` exposes three administrative actions for managing global set structure. Two of them gate on admin status; the third does not. Prerequisites • A Craft CMS instance with at least two global sets and a non-admin control panel user account. Impact A non-admin control panel user can reorder all global sets. While this does not expose or modify content, reordering global sets modifies the project config -- a versioned artifact that is typically committed to source control and deployed across environments. An attacker can create noise in the project config history, trigger config-sync conflicts, or manipulate the display order seen by all editors in the admin panel. The same non-admin user cannot create or delete global sets because those actions correctly enforce `requireAdmin()`.

Related

Alias · CVE (1)

  • CVE-2026-14793 A vulnerability was detected in Craft CMS up to 4.18.0.1. vulnerability

Weakness · CWE (1)

  • CWE-862 Missing Authorization weakness

References