GitHub Advisoryadvisory · Go

GHSA-9p92-x77w-9fw2 Mattermost makes Use of Weak Hash

MEDIUM Published 2025-09-15 Modified 2025-09-16 Official page ↗
Aliases
CVE-2025-9078
Ecosystem
Go
Packages
github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-328
Reviewed
2025-09-16

Affected packages

• Go github.com/mattermost/mattermost-server: >= 10.8.0, < 10.8.4 → fixed in 10.8.4 • Go github.com/mattermost/mattermost-server: >= 10.5.0, < 10.5.9 → fixed in 10.5.9 • Go github.com/mattermost/mattermost-server: >= 9.11.0, < 9.11.18 → fixed in 9.11.18 • Go github.com/mattermost/mattermost-server: >= 10.10.0, < 10.10.2 → fixed in 10.10.2 • Go github.com/mattermost/mattermost-server: >= 10.9.0, < 10.9.4 → fixed in 10.9.4 • Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250718075842-cd87e5c87737 → fixed in 8.0.0-20250718075842-cd87e5c87737

Description

Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.1, 10.9.x <= 10.9.3 fail to properly validate cache keys for link metadata which allows authenticated users to access unauthorized posts and poison link previews via hash collision attacks on FNV-1 hashing.

Related

Alias · CVE (1)

  • CVE-2025-9078 Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.1, 10.9.x <= 10.9.3 fail to properly validate… vulnerability

Weakness · CWE (1)

  • CWE-328 Use of Weak Hash weakness

References