GitHub Advisoryadvisory · npm
GHSA-9p95-fxvg-qgq2 simple-git vulnerable to Remote Code Execution when enabling the ext transport protocol
HIGH
Official page ↗
- Aliases
- CVE-2022-25912
- Ecosystem
- npm
- Packages
- simple-git
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-78
- Reviewed
- 2022-12-07
Affected packages
• npm simple-git: < 3.15.0 → fixed in 3.15.0
Description
The package simple-git before 3.15.0 is vulnerable to Remote Code Execution (RCE) when enabling the `ext` transport protocol, which makes it exploitable via `clone()` method. This vulnerability exists due to an incomplete fix of CVE-2022-24066.
Related
Alias · CVE (1)
- CVE-2022-25912 The package simple-git before 3.15.0 are vulnerable to Remote Code Execution (RCE) when enabling the ext transport protocol, which makes it… vulnerability
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-25912 advisory
- https://github.com/steveukx/git-js/commit/774648049eb3e628379e292ea172dccaba610504 web
- https://github.com/steveukx/git-js package
- https://github.com/steveukx/git-js/blob/main/docs/PLUGIN-UNSAFE-ACTIONS.md%23overriding-allowed-protocols web
- https://github.com/steveukx/git-js/releases/tag/simple-git%403.15.0 web
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3153532 web
- https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221 web