GitHub Advisoryadvisory · Maven
GHSA-9pp4-mx6x-xh36 Jenkins OWASP Dependency-Check Plugin has stored XSS vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2024-28153
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:dependency-check-jenkins-plugin
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-03-06
Affected packages
• Maven org.jenkins-ci.plugins:dependency-check-jenkins-plugin: < 5.4.6 → fixed in 5.4.6
Description
Jenkins OWASP Dependency-Check Plugin 5.4.5 and earlier does not escape vulnerability metadata from Dependency-Check reports, resulting in a stored cross-site scripting (XSS) vulnerability.
Related
Alias · CVE (1)
- CVE-2024-28153 Jenkins OWASP Dependency-Check Plugin 5.4.5 and earlier does not escape vulnerability metadata from Dependency-Check reports, resulting in… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-28153 advisory
- https://github.com/jenkinsci/dependency-check-plugin/commit/b3b286a9615603f0294eb740193d153d843fae3a web
- https://github.com/jenkinsci/dependency-check-plugin package
- https://www.jenkins.io/security/advisory/2024-03-06/#SECURITY-3344 web
- http://www.openwall.com/lists/oss-security/2024/03/06/3 web