GitHub Advisoryadvisory · npm
GHSA-9pv7-vfvm-6vr7 graphql Uncontrolled Resource Consumption vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-26144
- Ecosystem
- npm
- Packages
- graphql
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-400
- Reviewed
- 2023-09-21
Affected packages
• npm graphql: >= 16.3.0, < 16.8.1 → fixed in 16.8.1
Description
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance.
Note: It was not proven that this vulnerability can crash the process.
Related
Alias · CVE (1)
- CVE-2023-26144 Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the… vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-26144 advisory
- https://github.com/graphql/graphql-js/issues/3955 web
- https://github.com/graphql/graphql-js/pull/3972 web
- https://github.com/graphql/graphql-js/commit/8f4c64eb6a7112a929ffeef00caa67529b3f2fcf web
- https://github.com/graphql/graphql-js package
- https://github.com/graphql/graphql-js/releases/tag/v16.8.1 web
- https://security.snyk.io/vuln/SNYK-JS-GRAPHQL-5905181 web