GitHub Advisoryadvisory · npm

GHSA-9pw5-wx67-q964 @sequa-ai/sequa-mcp has Command Injection vulnerability

MEDIUM Published 2025-09-17 Modified 2025-09-25 Official page ↗
Aliases
CVE-2025-10619
Ecosystem
npm
Packages
@sequa-ai/sequa-mcp
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-77
Reviewed
2025-09-18

Affected packages

• npm @sequa-ai/sequa-mcp: < 1.0.14 → fixed in 1.0.14

Description

A vulnerability was detected in sequa-ai sequa-mcp up to 1.0.13. This affects the function redirectToAuthorization of the file src/helpers/node-oauth-client-provider.ts of the component OAuth Server Discovery. Performing manipulation results in os command injection. Remote exploitation of the attack is possible. The exploit is now public and may be used. Upgrading to version 1.0.14 is able to mitigate this issue. The patch is named e569815854166db5f71c2e722408f8957fb9e804. It is recommended to upgrade the affected component. The vendor explains: "We only promote that mcp server with our own URLs that have a valid response, but yes if someone would use it with a non sequa url, this is a valid attack vector. We have released a new version (1.0.14) that fixes this and validates that only URLs can be opened."

Related

Alias · CVE (1)

  • CVE-2025-10619 A vulnerability was detected in sequa-ai sequa-mcp up to 1.0.13. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References