GitHub Advisoryadvisory · Packagist
GHSA-9q29-jcjw-fw7h Moodle Incorrect Authorization vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2020-14321
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-863
- Reviewed
- 2025-05-08
Affected packages
• Packagist moodle/moodle: >= 3.9.0-beta, < 3.9.1 → fixed in 3.9.1
• Packagist moodle/moodle: >= 3.8.0-beta, < 3.8.4 → fixed in 3.8.4
• Packagist moodle/moodle: >= 3.6.0-beta, < 3.7.7 → fixed in 3.7.7
• Packagist moodle/moodle: < 3.5.13 → fixed in 3.5.13
Description
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.
Related
Alias · CVE (1)
- CVE-2020-14321 In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness